跳转至
-->

将python默认版本设为python3.6

系统里面同时安装了python2.7和3.6,今天安装mkdocs的时候提示其中的一个依赖需要py3.0,于是产生了修改python默认版本的需求。

使用软链的方式

1
2
3
4
5
6
cd /user/bin
sudo rm python
sudo ln -s python3.6m python
# 将python3链接至python
python -V
# Python 3.6.8

更新pip

设置python3后,可能pip会报错。此时可以通过尝试重装pip解决问题。